Results 1 to 6 of 6

Thread: Speedo No Go

  1. #1
    Join Date
    Nov 2006
    Posts
    216
    Total Downloaded
    0

    Speedo No Go

    Hi, my 09 street bob ( 35,000 ). and 136 miles into a trip to the south of france just stopped working at the first fuel station, symptyms were: No speed indication , No top gear light, No yellow low fuel light, and No self cancelling of indicators . Power was getting to the speedo in some form as the light remained on and the indicated milage of 136 remains. Fortunatly I could combine looking at the revcounter and when the sun didnt obscure it a very small sat nat speed indicated. No dramas we made it to the destination and I duly removed the sensor on the back of the gearbox and gave it a wipe over .... it was very clean, I was kind of hoping to find bebris. we are now back in UK and I need a fix.
    Q. Can the sensor be tested ? Or does one just change it out hoping its not the Expencive bit The Speedo its self . Any hep here greatly aprieciated Thank you. Rob.

    Join the Harley-Davidson Riders Club Great Britain

  2. #2
    Join Date
    Aug 2014
    Posts
    664
    Total Downloaded
    93.34 MB

    Re: Speedo No Go

    Did it refuse to tick over as well? My speed sensor went just after I got my Fat Bob and I had all the symptoms you're getting, plus the no tick over thing. New sensor from Jersey HD and it's been fine since (touch wood).
    Region 3, North East, Tyne & Wear

    Join the Harley-Davidson Riders Club Great Britain

  3. #3
    Join Date
    Nov 2006
    Posts
    216
    Total Downloaded
    0

    Re: Speedo No Go

    Quote Originally Posted by ss2 View Post
    Did it refuse to tick over as well? My speed sensor went just after I got my Fat Bob and I had all the symptoms you're getting, plus the no tick over thing. New sensor from Jersey HD and it's been fine since (touch wood).
    Well..... funny you should say that ! Very irratic tick over , half the time when you pull the clutch in, it hust dies . Thanks for your reply.

    Join the Harley-Davidson Riders Club Great Britain

  4. #4
    Join Date
    Jan 2013
    Posts
    3,120
    Total Downloaded
    113.35 MB

    Re: Speedo No Go

    Fault codes...

    P0502 VSS High/Open (Can-Bus)
    P0502 VSS Speed Failed Low
    P0503 VSS Speed Failed High

    Where to find fault codes.
    https://dgcustomcycle.com/tech/harle...es-04-present/
    Instant experts...... just add google.

    Join the Harley-Davidson Riders Club Great Britain

  5. #5
    Join Date
    Jul 2005
    Posts
    390
    Total Downloaded
    11.00 MB

    Re: Speedo No Go

    Quote Originally Posted by ss2 View Post
    Did it refuse to tick over as well? My speed sensor went just after I got my Fat Bob and I had all the symptoms you're getting, plus the no tick over thing. New sensor from Jersey HD and it's been fine since (touch wood).
    i've had the same and all the symptoms.
    like rob's there was no debris on the end of the sensor, it had just given up the ghost. new sensor and all's well.

    Join the Harley-Davidson Riders Club Great Britain

  6. #6
    Join Date
    Nov 2006
    Posts
    216
    Total Downloaded
    0

    Re: Speedo No Go

    Quote Originally Posted by chrissy View Post
    i've had the same and all the symptoms.
    like rob's there was no debris on the end of the sensor, it had just given up the ghost. new sensor and all's well.
    Thanks very much guys, New Speed Sensor ordered from Jersey .

    Join the Harley-Davidson Riders Club Great Britain

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •